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Trademarks

BARUDAN has made all possible efforts to supply trademark information about 
company names, products and services mentioned in this manual.
Trademarks indicated below were derived from various sources:

Barudan is a registered trademark of Barudan Co. Ltd.

TES is a trademark of Barudan Co. Ltd.
Realistic is a trademark of COMPUCON Computer Applications S.A.

MS-Windows 2000 /  Windows XP  is a trademark of Microsoft Corporation.
Windows, Windows 95, Windows NT are trademarks of Microsoft Corporation.
MS-DOS is a trademark of Microsoft Corporation.
IBM is a registered trademark of International Business Machines Corporation.
Hewlett-Packard is a trademark of Hewlett-Packard Company.
Microsoft Visual C++ V4.1 is a trademark of Microsoft Corporation.
PC is a trademark of International Business Machines Corporation.
Intel is a trademark of Intel Corporation.
Pentium is a trademark of Intel Corporation.

ZSK is a trademark of ZSK Stickmaschinen Gesellschaft mbH.
Tajima is a trademark of Tajima Industries Ltd. 
Barudan is a trademark of  Barudan Co. Ltd.
FMC is a trademark of Barudan Co. Ltd.
FDR is a trademark of Barudan Co. Ltd.
Pfaff is a trademark of its respective owner.
Melco  is a trademark of Melco Industries Inc..
Marco is a trademark of its respective owner.
Happy is a trademark of its respective owner.
Brother is a trademark of Brother Industries Ltd.
Toyota is a trademark of its respective owner.
Gemini is a trademark of Gemini Advanced Systems.
NC-Giken is a trademark of its respective owner.
Summagraphics is a registered trademark of Summagraphics Corporation.
Summasketch is a registered trademark of Summagraphics Corporation.
MM is a registered trademark of Summagraphics Corporation.
Microgrid is a registered trademark of Summagraphics Corporation.
GTCO is a trademark of GTCO Corporation.
Calcomp is a trademark of Calcomp, Inc.

All other accompanying logos, brands and product names are trademarks of their 
respective companies.
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Installation of the software
In order to start using the software you have to first install the 
contents of the CD to your PC. This procedure is referred to as “instal-
lation procedure”. Please follow the below listed instructions in order 
to successfully install TES Viewer 3.0 on your personal computer.
The TES Viewer 3.0 software comes with the TES Demo CD or alter-
natively you can download it from the TES 3 website.

In most personal computers the default drive setting for a CD-ROM 
drive is “D:”

1. Please insert the TES Demo CD-ROM into the CD-ROM disc 
receiver in your PC. From the main menu, go to “TES V3 Tryout”

     section  and click on “Install TES Viewer”.

After some seconds, the Installation procedure of the software 
will start automatically.
If this does not occur after a short while, you can run the instal-
lation procedure manually by going to the “Start” option
of Windows, select “Run”, type “D:\TESViewer\TESViewer.exe” and 
click on “OK”.

2. After some seconds the step-by-step installation of the software 
begins with the Welcome window. You can always abort the 
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     installation procedure by clicking on the “Cancel” button.
Click on “Next” to move on the next screen.

3. After reading and agreeing with terms given in the License 
Agreement, please click on “Next”.
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4. Now input your User Name and Company Name (if there is 
no “Company Name”, insert any character).



Installing TES Viewer:
Installation of the software

TE
S 

V
ie

w
er

 E
n

g
lis

h 
3-

01

8 Installing TES Viewer:
Installation of the software

TES V
iew

er En
g

lish 3-01

In
st

al
lin

g 
TE

S V
ie

w
er

9

5. Click on Next, and then select the directory where the software 
should be installed.
It would be recommended to use the default selected directory: 
C:\Barudan\TESViewer.

Simply click on “Next” to continue.
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6. The installation procedure has all necessary information to start. 
Click on the “Install” button to start.

7. The progress bar will indicate the stage of all files being installed, 
the procedure of installing the TES Viewer software application 
will finish when the bar is close to the end.
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Files and Folders

Open files 
A file must be opened with a program that recognizes that file type. 
For example, if you are trying to open a Stock Embroidery
Design (whether it resides on the computer, a CD, or a floppy disk), 
you must have a program open that can “see” it. Or if you have
a document file, a Word Processing program must be opened
in order to read and write the file.
1. Double-click on the icon on the Desktop or in “My Computer” 

that represents the program of your choice. This “launches” 
the program.

2. Click on “File/Open” to open a file.

Save/Save As files 
When you have made any changes to a file, or wish to save this 
design onto your computer...
1. Select “File/Save As” to give your design a name. Changes made 

after the initial saving need only “Save” because you already have 
a name.

2. Close the program if desired.
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Screens 
Open
From the Blank screen, a file can be opened.
1. Select “File/Open”.
2. At the top of the “Open Design File” box, there is a “Look In” 

Label with a downward (black) triangle. Browse there to locate 
the correct drive (C: A: or D) and folder. The large white rectangle 
in the center will display all of the files. Also, you must select the 
“File Type” i.e. (.DST, etc.). 

3. Click on a file, and choose “OK” in the box. The design will open 
into your TES Viewer screen.
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Design Views
Choose different ways to view your embroidery design.

1. Realistic
To view design in simulated embroidery, choose: View > Realistic View.

2. Zoom 
Use in Main Toolbar or choose: View > Zoom > In (or one 
of Zoom choices).

REALISTIC VIEW
 Feature that provides realistic 
simulation in “embroidery thread” 
of on-screen design .

NEW TERM

3. Stitch Points
To see or hide stitch points (needle penetrations), choose: View 
> Show/Hide Stitche Points.

STITCH POINTS VIEW
Feature that displays actual needle 
penetrations.

NEW TERM
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4. Redraw Design
To “stitch” the design on-screen choose: View > Redraw Design.

5. Stitch Colors
For thread palette on-screen, choose: Tools > Show/Hide
Stitch Colors.
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General

Background Color Click color box to set screen 
color.

Basic Menu
Language
Set your choice of language for the TES Viewer screen.
English (default language)

Unit System
Metric System (default) Millimeters 
English System = Inches
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Edit

Undo Undo last action.

Redo Restore UNDO.

View

Zoom

Full Screen Use full screen area without 
toolbars, rulers, etc.

Show/Hide Image Turn on or off image.

Show/Hide Grid Turn on or off grid.

Design

Execute “Generate” design in machine 
format for accurate stitch 
estimate.

Center Automatically create a perfect 
center (or, user-defined) origin.

Optimize Clean up small stitches and jumps.

Move to first Point Send a jump stitch to the origin 
point.
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Tools

Show/Hide Rulers Turn on/off on-screen rulers.

Show/Hide Scroll Bars Turn on/off on-screen rulers.

Ruler Use Ruler to measure distance 
between two points.

Protractor Use Protractor to measure 
angle of two points.

Set Grid Size Set values for Grid display.

Select Hoop Choose Hoop from list or create 
new one. 
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Window

Cascade Choose to “stagger” open 
windows.

Tile Choose to “stack” open 
windows.

Arrange Icons Arranges the icons 
of the design when having 
all designs minimized.

Toolbars

Rulers Show/hide on-screen rulers 
(at left side and top).

Scroll Bars Show/hide on-screen bars 
(at right side and bottom).

Windows Displays all open windows.
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Help
Internet Help Connect to internet to get 

information on working with 
the TES Viewer.

Register your software
and get free designs

Connects you to TES 3.0 web 
site for product registration. 

Connect to

Barudan For further information 
and support.

Embroidery Marketplace To browse and select new 
designs, fonts and training 
material.

Compucon Connect to the corporate 
Compucon website.

About TES Viewer View software version infor-
mation.
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Open Design
Open an existing stitch file into TES Viewer.
»Choose: File > Open; choose: folder > (embroidery) file > OK.
The selected design will open.

Machine disk

Read
Read design file from commercially formatted floppy.
»Choose: File > Machine disk > Read ; select machine format (left) 
> design (right) > Read.

The selected design will open.

You can have multiple screens open
at the same time. View screens 
in Window drop-down menu.

See Close Design in next section.

Opening or Importing (stitch) Files
New Design
Open a blank screen in TES Viewer to load a design from the Design 
Library.
»Choose: File > New. A blank screen will open.

MACHINE DISK
A commercially embroidery formatted 
floppy disk.

NEW TERM
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Write
Write current design to machine floppy disk.
»Choose: File > Machine disk; choose format > > Name > Write >OK.

Format
Format a new floppy disk as a commercial machine disk.
»Choose: File > Machine disk > Format ; select machine format 
(left) > Format.

1. Format
2. Design designation

3. Machine specifics
4. Write or Exit

5. Design list

1

2

5

3 4
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Design Browser
Use “Design Browser” (works like Windows Explorer) to view all 
stitch files on computer or storage device.
»Choose: File > Design Browser; choose: folder > design > Open.

The selected design will open.

1. Folder name
2. Drive contents
3. Folder contents
4. File name

5. Format list
6. File info.
7. Color blocks
8. Open design

1

2

4

6

3

7

5

8

DESIGN BROWSER
A window designed to view all stitch files 
on computer or storage device.

NEW TERM
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1.Choose design(s) to convert
2.Choose future format and location

1

2

Convert Design
Change one or more designs to a specific machine format.
»Choose: Utilities > Convert Designs; select (from “Open/Save” 
box): Drive > folder > format >designs > OK.
Then, choose: (from “Select Catalogue” box) Drive or Network > 
Folder > Format > OK.
The selected designs will be changed to chosen format and saved 
into selected location.

Hold CTRL key to select multiple designs. 
The selected designs formats can be different.

CONVERT DESIGNS
Feature designed to perform a batch con-
version from one stitch format to another.

NEW TERM



Basic File Handling:
Opening or Importing (stitch) Files

TE
S 

V
ie

w
er

 E
n

g
lis

h 
3-

01

24 Basic File Handling:
Opening or Importing (stitch) Files

TES V
iew

er En
g

lish 3-01 Ba
sic

 Fi
le

 H
an

dl
in

g

25

Info Card
The Info Card is automatically saved with every TES Viewer design. 
Every detail of the design is recorded, with areas to include your 
comments, and customer information.

1. Design information
2. Design categories
3. Stitches statistics
4. Design ownership
5. Thread usage

4

3
5

1

2

INFO CARD
Design information is recorded, with 
areas for comments and customer 
information.

NEW TERM
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1. File handling tools
2. Window drive - Left - Right
3. Window folder - Left - Right

4. Active folder
5. Action confirmation box

5

1

3

2

4

Design Management
Manage files using two windows (of your choice) at-once.
»Choose: Utilities > Design Management >(copy/paste, etc).
The Design Management Screen will open to organize files 
between two windows.

DESIGN MANAGEMENT
Manage files using two windows at-once.

NEW TERM
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Saving or exporting (stitch) Files
Save
Save on-screen design.
»Choose: File > SAVE.
The current design will be saved, overwriting the existing one.

Save as
Save current (previously saved) design “as” (a new name).
»Choose: File > Save As > Name > OK.
The current design will be saved with new name.

 Send as Email
Open email program and attach current design.
»Choose: File > Send as Email.
Your email program will open for preparation.

If changes have been made to a design 
since the last save, an “*” will appear by 
design name.

Save an additional “version” of a design if 
making a lot of changes.
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1. Design information
2. Design Colors
3. Print layout options

4. Printer setup
5. Block color page

1

3

2

5 4

Print
Print on-screen design with relative color information.
»Choose: File > Print.
A “style sheet” will open for user-defined settings.

Customize the design style sheet to your specific 
needs. Experiment for the best design.

PRINT
On-screen design “style sheet” with 

relative information.

NEW TERM
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You will be prompted to save if design
  has changes.

Close Design
Close current TES Viewer screen.
»Choose: File > Close Design.
Current design (window) will close.
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View in Real Stitches
Click Realistic View mode to see embroidery stitches.

Realistic View 
for 3D.
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What you’ll learn:
In this section you will learn the details of:

How to Open Library Designs
Functionality of Library Designs

Design Library

TES Viewer has a Library of designs for you to  download for free from 
the Internet. Since the designs were created with TES, they have full 
block edit capabilities. So, they are great for practicing the skills learned 
in these manuals. Be certain to watch them “stitch out”, either on-
screen (with Redraw Design), or on your embroidery machine. 
You will see how one digitizer made choices about “routing”, settings, 
stitch types, and more.

Open Design Library
To open the library of embroidery designs:
»Choose: Create > Design Library.

>Choose a Category
»Click a category in left-hand column.
The contents of the category open into the right-hand column.

>Choose a Design
»Click on a design in the right-hand column to highlight, 
and click “OK”.
The design will open into TES Viewer screen.  

Get 100 Free Designs from the Barudan 
website.
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1

1. Choose a category
2. Click a design.

3. Click OK

3

2
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Optimize Design
Clean up small and unnecessary stitches and jumps with Optimize. 
Nearly all machine formats would benefit from using it. 
To clean up design:
»Choose: Design > Optimize.

Center Design
Create a perfect center origin point. To center design:
»Choose: Design > Center.

 You can clean up stitches up to 8/10th 
mm without losing vital detail; especially 

if a design is breaking thread.

CENTER DESIGN
Create a perfect center (or other)
origin point.

ORIGIN POINT
Location of beginning and ending 
stitches of a design.

NEW TERMS

TES Viewer places a start and end point 
instantly. Notice “blinking” cursor (now in 
center of design).

OPTIMIZE
Clean up small and unnecessary stitches 
and jumps.

NEW TERM
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Execute Design
For accurate stitch count of your design, execute it in the intended 
machine format. The “working stitch count” (at top of screen) 
doesn’t include jumps, etc. To get stitch count:
»Choose: Execute; select machine from list.

Execute is only for calculation. 
The design doesn’t change. 

Redraw Design
“Stitch” your design on-screen before taking it to the embroidery 
machine. Often you can catch and change problems. To redraw 
design:
»Click: Redraw; Click:Start Drawing.

1. Click Redraw icon.
2. Click Start Drawing.

A. STOP or “freeze” at any time.
B. Change speed while drawing.

1

2 A B

EXECUTE DESIGN
 Calculate design in the intended 

machine format for accurate stitch count.

NEW TERM

REDRAW DESIGN
“Stitch” your design on-screen 

NEW TERM
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Find Appropriate Hoop
“Hoop” your design on-screen to find suitable size. 
To display hoop around design:
»Choose: View >Show/Hide Hoop; choose from list.

1. Choose Hoop from list.

1

Create Custom Hoop
If there isn’t a hoop like your’s, create it. To create new hoop:
»Choose: New Hoop; Follow wizard.

1. Choose “New Hoop”.
2. Choose Hoop shape.
3. Type Hoop name.
4. Type comments.
5. Click “Next>”

2

3

4

5
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»Click Finish (in next box) to save hoop.

1. Type Hoop size.
2. Type Margin size.

3. Click “Next>”

Design displayed 
in Hoop.

1

2

3
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Change Size of Design
At any time you can change the size of your embroidery design. 
Even select parts of a design to resize, rotate, or flip. 
To change design size:
»Choose: Modify > Change Size.

1. Choose Modify > Change Size.
Transform Design box opens.

2. Choose measurement type.
3. Change one dimension. 

Both will change if “lock” is enabled.
4. Click OK.

A. Flip horizontally or vertically.
B. Rotate either direction.
C. Offset location.

1

A

B

2

C

3
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